Univera Healthcare logo
Login | Register | Forgot Username | Forgot Password
By Phone
By Email
By Mail
Visit Us In-Person
News and Updates
Print Forms
About Us
Compliance Notices
Employer Update | April 2018
Employer Update | April 2018

Important Information to Qualify for Small Group Health Plans

In order to comply with the Affordable Care Act, an employer must have at least one common-law employee enrolled to qualify as a group health plan.  Businesses that do not have any common-law employees enrolled are no longer eligible for a group health plan and must be transitioned to individual coverage

Sole owners/partners and their spouse are not considered common law employees regardless of whether they are listed on the quarterly wage report.

Continuing through January 1, 2019, groups we have identified as no longer qualifying for group coverage will receive a notification by mail.

Additional Details:

  • If you believe you still qualify for small group coverage, please contact your Broker or dedicated account manager to work with an underwriter on resolution.
  • If you do nothing, you will be automatically enrolled in an individual market plan similar to the plan you have now.
  • If you want to select another individual plan other than what you are mapped to, you will need to complete an application for the plan you wish to enroll in. You can contact 1-888-576-6594 for assistance with Individual market plans.
  • If you are Medicare eligible you will not be automatically enrolled in a plan. For help selecting a plan, you can call 1-844-596-0345 or visit univeramedicare.com.

Alternate plan options can be found on our website under Individual & Families.

 

home     news & updates     print forms     about us     fraud & abuse     glossary     accreditations   
Language Assistance and Non-Discrimination Notice

Copyright © 2019, Univera Healthcare, an Excellus company. View our Web Privacy Policy for information on how we protect your privacy. Use of this site indicates your acceptance of our Terms of Use. You will need Internet Explorer or Google Chrome to use the secure features of this site.